Ask your Symfony questions! Pay money and get answers fast! (more info)

What causes mod_fcgid errors? Symfony

  • SOLVED

Very odd. Not sure if this is a Symfony error or an Apache/PHP one. I set up the [[LINK href="http://diyquestionsanswered.com/"]]diyquestionsanswered[[/LINK]] site yesterday and it was working. It was working this morning and then suddenly stopped working. No changes were made to the site that I know of. It is running on the same server as the site you are currently reading. I look in the Apache error log and I see this:


[Fri Apr 02 14:22:23 2010] [warn] mod_fcgid: stderr: Action "sf/sf_web_debug" does not exist.
[Sat Apr 03 18:59:20 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Sat Apr 03 18:59:20 2010] [error] [client 67.84.91.169] Premature end of script headers: index.php
[Sat Apr 03 19:01:25 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Sat Apr 03 19:01:25 2010] [error] [client 67.84.91.169] Premature end of script headers: index.php
[Sat Apr 03 19:01:37 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Sat Apr 03 19:01:37 2010] [error] [client 67.84.91.169] Premature end of script headers: index.php
[Sat Apr 03 19:06:31 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Sat Apr 03 19:06:31 2010] [error] [client 67.84.91.169] Premature end of script headers: index.php
[Sat Apr 03 19:09:04 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Sat Apr 03 19:09:04 2010] [error] [client 67.84.91.169] Premature end of script headers: index.php


What would cause this error?

My php5.fcgi file has not changed at all:

#!/bin/bash
PHPRC=$PWD/../etc/php5
export PHPRC
umask 022
export PHP_FCGI_CHILDREN
SCRIPT_FILENAME=$PATH_TRANSLATED
export SCRIPT_FILENAME
exec /usr/bin/php5-cgi


Answers (2)

2010-04-03

Martin Palacio answers:

Symfony version? SO/Apache/PHP version?

If you are under Linux (ex. Ubuntu), it could be some missing apache configuration, due to a software/system upgrade.

Check [[LINK href="http://www.phwinfo.com/forum/alt-apache-configuration/352296-action-sf-sf_default-does-not-exist.html"]]this link[[/LINK]]...maybe it gives you some guidance.

2010-04-03

casivaagustin answers:

Mmm, seems that the directory sf under sf_web_dir is missing. Try the follow

1 - Clear the cache
2 - publish the assets, symfony plugin:publish-assets
3 - Check if the sf dir in the web folder exists and is accesible.
4 - If no exist copy the sf folder from other project.

Cheers