logo
Ask your Symfony questions! Pay money and get answers fast! (more info)

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.

$10
sfSimpleCMSReloadedPlugin does not load routes

Symfony 1.4 using Propel 1.6.

This seems to be the same problem that I face:

http://sourceforge.net/tracker/?func=detail&aid=3340225&group_id=559188&atid=2268685

I downloaded the package for sfSimpleCMSReloadedPlugin. Then I used scp to move it to my server.

This plugin needs Propel 1.5. We have 1.6, which I assume will work, unless there were some backwards breaking changes.

If I go to:

frontend_dev.php/sfSimpleCMSReloadedPlugin

I get:

404 | Not Found | sfError404Exception
Action "sfSimpleCMSReloadedPlugin/index" does not exist.

If I go here:

frontend_dev.php/sfSimpleCMSReloadedAdmin

I see this error:

500 | Internal Server Error | sfConfigurationException
The route "sf_simple_cms_page_collection" does not exist.

The plugin has this route class:

class sfSimpleCMSReloadedRouting
{

static public function listenToRoutingLoadConfigurationEvent(sfEvent $event)
{
$r = $event->getSubject();

// prepend our routes
$r->prependRoute('sf_cms_delete', new sfRoute('/cms_delete/:sf_culture/:slug', array('module' => 'sfSimpleCMSReloaded', 'action' => 'delete'), array('slug' => '.*')));
$r->prependRoute('sf_cms_toggle_publish', new sfRoute('/cms_publish/:slug', array('module' => 'sfSimpleCMSReloaded', 'action' => 'togglePublish'), array('slug' => '.*')));
if (sfConfig::get('app_sfSimpleCMSReloaded_use_l10n', false))
{

$r->prependRoute('sf_cms_show', new sfRoute('/cms/:sf_culture/:slug', array('module' => 'sfSimpleCMSReloaded', 'action' => 'show'), array('slug' => '.*')));
}
else
{
$r->prependRoute('sf_cms_show', new sfRoute('/cms/:slug', array('module' => 'sfSimpleCMSReloaded', 'action' => 'show'), array('slug' => '.*')));
}
}

}

But it seems like the routes never get loaded?

I enabled this plugin in settings.yml and in the Project file and I cleared the cache. I still can't get this plugin to show up anywhere.

What should I check next?

Lawrence Krubner | 12/17/12 at 5:39pm Edit
Tutorial: How to assign prize money


(0) Responses

See a threaded view of answers?

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

This question has expired.





Current status of this question: Community pot



Please log in to add additional discourse to this page.





Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.